Do all the themes work with the latest version of WP and Woo Commerce?

Yes, it is our duty to always keep the themes up-to-date and working with the latest version of WordPress and Woo Commerce plugin. Our themes are developed and fine-tuned for WordPress 3.0 or higher, any version prior to that may have problems with some theme functionality. We provide life-time updates and we add new amazing features all the time.